所需依赖以及安装 Nodejs 8.11.x (Note that v9.x is not yet supported) PostgreSQL 9.5 or greater jq docker-ce docker-compose git 在上一篇的《Hyperledger Fabric 多机部署》已经部署好了 Fabric 网络,这里用 CLI 那台机器来部署 Hyperledger Explorer,所以有些依赖已经安装好了。 安装 PostgreSQL sudo apt-get install wget ca-certificates wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add - sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ `lsb_release -cs`-pgdg main" >> /etc/apt/sources.list.d/pgdg.list' sudo apt-get update sudo apt-get install postgresql postgresql-contrib ##修改密码 sudo -u postgres psql -c "ALTER USER postgres PASSWORD 'postgres';" 安装 jq apt-get install jq jq --version 代码配置 Clone 项目代码 git clone https://github.

阅读全文

官方的first-network执行一个脚本单机 docker 就可以启动 fabric 网络环 很多书和网络上也都是基于first-network教学,下面教程基于拆解first-network,不但对我们更深入了解 fabric 网络搭建有很大帮助,也有利于我们真实生产环境的搭建操作。 主机列表 节点 IP order.example.com 192.168.11.11 peer0.org0.example.com 192.168.11.12 peer1.org0.example.com 192.168.11.13 peer0.org1.example.com 192.168.11.14 peer1.org1.example.com 192.168.11.15 由于域名并非真实解析的公网,所以需要将以上加入各个主机的/etc/hosts 环境依赖安装 以下依赖安装没有特别说明需要在各个主机中安装操作 docker 安装 apt-get update apt-get install \ apt-transport-https \ ca-certificates \ curl \ gnupg-agent \ software-properties-common curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add - add-apt-repository \ "deb [arch=arm64] https://download.

阅读全文

作者的图片

Ryan是菜鸟 | LNMP技术栈笔记

一步一个脚印,一直在路上!记录LNMP技术栈,Web架构,区块链等笔记

菜鸟码农

南京